[squeak-dev] MC fix-while-compiling broken

Igor Stasenko siguctua at gmail.com
Wed Apr 28 02:41:56 UTC 2010

On 28 April 2010 04:42, David T. Lewis <lewis at mail.msen.com> wrote:
> On Wed, Apr 28, 2010 at 12:44:32AM +0300, Igor Stasenko wrote:
>> I tried to load the VMMaker in 4.1 image
>>       (Smalltalk hasClassNamed: #MCMcmUpdater)
>>               ifTrue: [(Smalltalk at: #MCMcmUpdater)
>>                               updateFromRepositories: #('http://squeaksource.com/VMMaker' )]
>>               ifFalse: [self notify: 'MonticelloConfigurations not installed in this image']
>> during the load it finds a syntax error in one of the methods  ( -16
>> written as: - 16)
>> i fixed it and pressed accept, then MC happily continued compiling methods,
>> but at the stage when it going to install everything, i got DNU
>> because a compiled method being nil.
>> Seem like a method, which i fixed is lost in void and not remembered by MC. :((
> Hmm... is this because I have a series of update maps in SqS/VMMaker, and
> the MCMcmUpdate tries to load them all in sequence? The earlier maps would
> point to versions of VMMaker that still have the "- 16" syntax problem.
> So I probably should just delete the old versions of update-dtl.N.mcm,
> right?

Well, this will not make bug in MC fixed :)

> Dave

Best regards,
Igor Stasenko AKA sig.

More information about the Squeak-dev mailing list