[squeak-dev] [4.1] Installation and test case for SqueakDBX

Hannes Hirzel hannes.hirzel at gmail.com
Tue Apr 20 17:32:24 UTC 2010

I did an installation in a fresh image.

I get an error again (see screenshot).

Maybe I did not install Squeak properly on Ubuntu 9.10.

I just downloaded the image and the VM from

I unpacked the VM and double clicked on squeak.sh (hidden in the bin directory).
Then I am prompted for an image



"I installed SqueakDBX ( http://www.squeakdbx.org ) with the following commands"

  (Installer ss project: 'MetacelloRepository') install:
  (ConfigurationOfSqueakDBX project version: '1.1') load

"Then I tried to access a local mySQL database (Ubuntu 9.10) with an
adapted code snippet from the method testExampleConnection"

| conn connectionSettings |
      connectionSettings := DBXConnectionSettings
                      host: ''
                      port: '3306'
                      database: 'lex'
                      userName: 'hh2'
                      userPassword: 'something'.
      conn := DBXConnection platform: DBXMySQL4Platform new settings:
      conn connect.
      conn open.

"Alternatively I tried DBXMySQL4Platform"

On 4/20/10, Mariano Martinez Peck <marianopeck at gmail.com> wrote:
> Hi Hannes. I downloaded a Squeak 4.1 and I cannot reproduce the problem. I
> did exactly what you said, but it worked for me.
> Can you take a fresh Squeak 4.1, do exactly the same you said in the mail
> and try again ?
> Cheers
> Mariano
> On Tue, Apr 20, 2010 at 4:43 PM, Hannes Hirzel
> <hannes.hirzel at gmail.com>wrote:
>> Here it is. Thank you for your willingnett to look into it.
>> Hannes
-------------- next part --------------
A non-text attachment was scrubbed...
Name: Squeak4.1-SqueakDBXerrorOnUbuntu9.10.png
Type: image/png
Size: 13952 bytes
Desc: not available
Url : http://lists.squeakfoundation.org/pipermail/squeak-dev/attachments/20100420/22f6269e/Squeak4.1-SqueakDBXerrorOnUbuntu9.10.png

More information about the Squeak-dev mailing list