2016-01-17 19:10 GMT+01:00 Ben Coman <btc@openinworld.com>:
I find LockOwnership a bit cumbersome.  I guess you don't want just
Lock but to include the sense of ownership.  Would you consider one of
* Locker   "A person or thing that does an action indicated by the
root verb" [1]
* Lockee   "Less commonly added to verbs to form words meaning a
person or thing that is the subject of that verb (ie, who or that does
an action), especially where a passive sense of the verb is implied."
* OwnLock
* OwnedLock

To choose better class name we should take into account how we will use it.
Could you suggest names for #acquire and #release in context of your class name?
("locker acquire" is not good)

If people think that simple Lock is good for this purpose we can use it.