Nothing will make me happier. This time next week this problem will be solved. 

On Apr 7, 2016, at 9:35 AM, Eliot Miranda <> wrote:

Hi Chris,

    how about we meet v soon and u show you how straight forward it is, and you make a new video.  I feel frustrated (& worse; the phrase FUD comes to mind) to read messages like Ben's and your's, when the page documents how to build a VMMaker image via a script, and when the built image includes a workspace with doits for launching the simulator in many configurations.


_,,,^..^,,,_ (phone)

On Apr 7, 2016, at 6:02 AM, Chris Cunnington <> wrote:

I’m happy to see that people are still watching that video of mine. 
I made it work, sort of, by using very old images. I think it’s 2.2 or something. 

To my knowledge the simulator is broken and unusable. Like Alien FFI, it’s something you hear about, assume is a real thing, and then eventually find out it is not. In the hands of experts? Yes. But neither the simulator nor Alien is a mass market product. 

The simulator does not work with the Interpreter vm with any image. The simulator works for Cog if you are an expert. 
I’d be utterly fascinate if somebody could prove me wrong on this. I’d probably make a new video. 

Let me put it this way: 


On Apr 7, 2016, at 8:53 AM, Ben Coman <> wrote:

One of the advertised niceties is running the VM in a simulator.  I've
been wondering for a while how to try it.  I found this ancient
which saves current image as 'source.image'
then in original image does...
   (InterpreterSimulatorLSB new openOn: 'source.image') test
as advised at 2:15, but I get "Error: basicNew: failed"
at the line methodCache := Array new: MethodCacheSize.
where MethodCacheSize is nil.

Is this still the correct way to invoke the simulator?

I tried also "(StackInterpreterSimulatorLSB new openOn: 'source.image') test"
with same result.

If I use the example at the bottom of StackInterpreterSimulator class comment
I get "Error: incomaptible image format"

Also btw, the class comment of SimulatorMorph references
Simulator>>openAsMorph which doesn't exist. Should this be

I'm running on Linux-x86 platform.

cheers -ben