On 26.11.2014, at 23:42, Eliot Miranda <eliot.miranda@gmail.com> wrote:

No.  Bert suggested (IIRC) ImmediateFloat64 and BoxedFloat64 and I went with SmallFloat64 and BoxedFloat64 for two reasons.  SmallFloat64 because I like the symmetry with SmallInteger, and because this name scheme gracefully admits SmallFloat32, BoxedFloat32 and BoxedFloat80 if ever there was the energy to add them.

Here’s my message (sent private to Eliot to not prolong the bikeshedding):

From: Bert Freudenberg <bert@freudenbergs.de>
Subject: Re: Float hierarchy for 64-bit Spur
Date: 24. November 2014 11:50:34 MEZ
To: Eliot Miranda <eliot.miranda@gmail.com>


On 21.11.2014, at 19:08, Eliot Miranda <eliot.miranda@gmail.com> wrote:
I think I'll go with

Float
 |
 +------- BoxedDouble
 |
 +——— SmallDouble

Sounds okay. I just had another thought: use "Float64" instead of "Double". That is how JavaScript names it, and I like how it communicates exactly what it is without having to implicitly know about the IEEE standard's nomenclature. Also, with the digits in the name it screams "low level", and would easily extend to 32 and 128 bit floats.


Float
 |
 +------- BoxedFloat64
 |
 +——— SmallFloat64


- Bert -


- Bert -