Hi Guido,

On Wed, Mar 28, 2018 at 4:34 AM, Guido Chari <charig@gmail.com> wrote:

I am not able to generate the sources for the VM.

I am following these steps:

1. Download a squeak image (MAC 32 bits) from the official website. 

I have to do so because if I run "buildspurtrunkvmmakerimage.sh" from the latest Cog branch of opensmalltalk I got a dmg and when the script (or me) tries to open it, it appears a warning (the following disk image could not be opened) and nothing more happens.

What happens if you try and mount the .dmg manually?  What is the value of your  Security & Privacy setting "Allow downloaded apps from:"?  Mine is "Mac App Store and identified developers"

2. When I file in the UpdateSqueakTrunkImage it hangs in: 'intalling kernel-nice.1127' so I am not able to update the image.

Have you tried  buildspurtrunkvmmaker64image.sh?  I haven't tested the 32-bit build in a while.  I'll try and take a look.  But I successfully built an image and generated sources from it very recently, in line with the recent commits to image/getGoodSpur64VM.sh on March 17th (22d116ba79526555621cfd7c4632b5d40f403d98).

3. If I try to generate sources without updating the image running "VMMaker generateSqueakSpurCog64VM" I got a PrintFormatString>>transformVMMaker mnu.

Do you have the Printf package loaded?  If you look at the manifest in image/BuildSqueakSpurTrunkVMMakerImage.st you can see all the packages and repositories that go into making a VMMaker image.  You could try and update manually.  Perhaps a script to update based on the manifest would be useful.  Sorry this isn't going smoothly for you.  Its strange because I was able to do it myself earlier this month. 


Can anybody point me out what am I doing wrong?

Other than the Security and Privacy settings perhaps preventing you from mounting the .dmg I can;t think of anything that would be different between my testing and your usage.
Best Regards,

best, Eliot