Smalltalk has several attractions to people, by domain, I mean. I always think people have to pick either between a GUI app or a web app to explore Smalltalk. The truth is the vm is a domain that also attracts people. This came to me as a surprise, but I’m probably in the minority. 

For example, there is a professor at UCSF who has a project called ANTLR [1]. I had a talk with him on Twitter yesterday and he is brining several grad students to OopluCon 2016 this Sunday. They want to learn about vm construction, so the Cog presentation is a powerful draw to them. 

I imagine Eliot will be swarmed with people on Sunday. I’m not leaving San Francisco until Tuesday, so perhaps I can go to anywhere he directs on Monday to spend half an hour talking about the simulator. I’ll do some preparatory exploring in anticipation, refreshing my memory on the subject, reading the document he mentioned, etc. Maybe he won’t be swarmed and we can just look at it at The Box SF, which would be the easiest thing, I imagine. 

After that, I’ll make what I learn about using the simulator the first video on, which will be the first of what will ultimately be hundreds. I imagine that the attraction of that video, that is to say, Eliot’s work, will be as riveting to the wider world, as to the internal Smalltalk community, to the ANTLR team and many others. 



On Apr 7, 2016, at 11:12 AM, Ben Coman <> wrote:

Just a discover-ability issue.  I googled "simulator" and that is what
turned up.

A new video would be real nice, and especially great if it also
included a sample of actual debugging the simulated VM.  Maybe this
would be something cool to drop on ycombinator/reddit, together with a
link to Eliot & Clement's partial read barrier paper ?

cheers -ben

On Thu, Apr 7, 2016 at 9:38 PM, Chris Cunnington <> wrote:

Nothing will make me happier. This time next week this problem will be solved.


On Apr 7, 2016, at 9:35 AM, Eliot Miranda <> wrote:

Hi Chris,

   how about we meet v soon and u show you how straight forward it is, and you make a new video.  I feel frustrated (& worse; the phrase FUD comes to mind) to read messages like Ben's and your's, when the page documents how to build a VMMaker image via a script, and when the built image includes a workspace with doits for launching the simulator in many configurations.


_,,,^..^,,,_ (phone)

On Apr 7, 2016, at 6:02 AM, Chris Cunnington <> wrote:

I’m happy to see that people are still watching that video of mine.
I made it work, sort of, by using very old images. I think it’s 2.2 or something.

To my knowledge the simulator is broken and unusable. Like Alien FFI, it’s something you hear about, assume is a real thing, and then eventually find out it is not. In the hands of experts? Yes. But neither the simulator nor Alien is a mass market product.

The simulator does not work with the Interpreter vm with any image. The simulator works for Cog if you are an expert.
I’d be utterly fascinate if somebody could prove me wrong on this. I’d probably make a new video.

Let me put it this way:


On Apr 7, 2016, at 8:53 AM, Ben Coman <> wrote:

One of the advertised niceties is running the VM in a simulator.  I've
been wondering for a while how to try it.  I found this ancient
which saves current image as 'source.image'
then in original image does...
  (InterpreterSimulatorLSB new openOn: 'source.image') test
as advised at 2:15, but I get "Error: basicNew: failed"
at the line methodCache := Array new: MethodCacheSize.
where MethodCacheSize is nil.

Is this still the correct way to invoke the simulator?

I tried also "(StackInterpreterSimulatorLSB new openOn: 'source.image') test"
with same result.

If I use the example at the bottom of StackInterpreterSimulator class comment
I get "Error: incomaptible image format"

Also btw, the class comment of SimulatorMorph references
Simulator>>openAsMorph which doesn't exist. Should this be

I'm running on Linux-x86 platform.

cheers -ben