We build with 20.04. No older runners available on GitHub. We should drop support for 18.04 ... 😎


From: Tobias Pape <Das.Linux@gmx.de>
Sent: Tuesday, November 28, 2023 9:46:16 PM
To: Open Smalltalk Virtual Machine Development Discussion <vm-dev@lists.squeakfoundation.org>
Subject: [Vm-dev] Re: Please test | Relase candidate for OSVM 2023
 

Please remember Ubuntu 18 has reached "normal" EOL in April already:

https://ubuntu.com/blog/ubuntu-18-04-eol-for-devices

And it ships with Glibc 2.27
(Even debian buster has 2.28…)

If we want to support older GLIBCen, we have to do strange dances:
- for example, explicitly marking symbols to use "old" versoines ones
  https://web.archive.org/web/20160107032111/http://www.trevorpounds.com/blog/?p=103
  (this seems excessive)
  (but pepople seem to have managed that: https://stackoverflow.com/a/69139182 )
- link statically, but that is, imho a Very Bad Idea™
- Kill the version info and cross fingers: https://stackoverflow.com/a/73388939
- Build on ubuntu 18.04. I don't know whether github still has this for runners…


it's messy

best regards
        -Tobias

> On 28. Nov 2023, at 17:38, <christoph.thiede@student.hpi.uni-potsdam.de> <christoph.thiede@student.hpi.uni-potsdam.de> wrote:
>
>
> Hi there,
>
> happy to report a green bar for SimulationStudio under 6.0 using the new VM on Windows 10 22H2 (squeak.cog.spur_win64x64).
>
> However, I cannot start the VM on WSL 1/Ubuntu 18.04 (squeak.cog.spur_linux64x64):
>
> $ squeak /path/to/squeak60.image
> /usr/bin/squeak/lib/squeak/5.0-202311211431-64bit/squeak: /lib/x86_64-linux-gnu/libm.so.6: version `GLIBC_2.29' not found (required by /usr/bin/squeak/lib/squeak/5.0-202311211431-64bit/squeak)
>
> With the previous VM, I did not have this issue.
>
> $ file /usr/bin/squeak/lib/squeak/5.0-202311211431-64bit/squeak
> /usr/bin/squeak/lib/squeak/5.0-202311211431-64bit/squeak: ELF 64-bit LSB executable, x86-64, version 1 (SYSV), dynamically linked, interpreter /lib64/ld-linux-x86-64.so.2, BuildID[sha1]=db26fa3de79c67698b6850c38f487f719f2afd9c, for GNU/Linux 3.2.0, with debug_info, not stripped
> $ file /usr/bin/squeak.bak20231128/lib/squeak/5.0-202204190959-64bit/squeak
> /usr/bin/squeak.bak20231128/lib/squeak/5.0-202204190959-64bit/squeak: ELF 64-bit LSB executable, x86-64, version 1 (SYSV), dynamically linked, interpreter /lib64/ld-linux-x86-64.so.2, for GNU/Linux 3.2.0, BuildID[sha1]=c7e8211b70431cf23cd03d1531d6b82f16366438, with debug_info, not stripped
>
> Should the VM work out of the box without installing extra dependencies? If yes, could there something be missing in the build process? If not, can we please make the documentation on how to install the missing dependencies very accessible (e.g., include a readme in the VM bundles)?
>
> Best,
> Christoph
>
> ---
> Sent from Squeak Inbox Talk
>
> On 2023-11-21T17:02:16+00:00, marcel.taeumel@hpi.de wrote:
>
>> Hi all --
>>
>> Please test this VM version (includes a small change log):
>> https://github.com/OpenSmalltalk/opensmalltalk-vm/releases/tag/202311211431
>>
>> Choose your preferred platform. Focus on cog.spur flavors for 64-bit machines.
>>
>> Thank you!
>>
>> Best,
>> Marcel